mirror of
https://github.com/soywod/himalaya.git
synced 2025-04-20 00:03:40 +00:00
29 lines
645 B
Nix
29 lines
645 B
Nix
{
|
|
pimalaya ? import (fetchTarball "https://github.com/pimalaya/nix/archive/master.tar.gz"),
|
|
...
|
|
}@args:
|
|
|
|
pimalaya.mkDefault (
|
|
{
|
|
src = ./.;
|
|
version = "1.0.0";
|
|
mkPackage = (
|
|
{
|
|
lib,
|
|
pkgs,
|
|
rustPlatform,
|
|
defaultFeatures,
|
|
features,
|
|
}:
|
|
pkgs.callPackage ./package.nix {
|
|
inherit lib rustPlatform;
|
|
apple-sdk = pkgs.apple-sdk;
|
|
installShellCompletions = false;
|
|
installManPages = false;
|
|
buildNoDefaultFeatures = !defaultFeatures;
|
|
buildFeatures = lib.splitString "," features;
|
|
}
|
|
);
|
|
}
|
|
// removeAttrs args [ "pimalaya" ]
|
|
)
|