57 lines
1.6 KiB
Bash
57 lines
1.6 KiB
Bash
# Maintainer: Tim Visee <tim@visee.me>
|
|
#
|
|
# This PKGBUILD is managed externally, and is automatically updated here:
|
|
# - https://gitlab.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
|
|
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
|
|
|
|
pkgname=ffsend-git
|
|
pkgver=0.0.0 # automatically set in CI, see: /.gitlab-ci.yml
|
|
pkgrel=1
|
|
pkgdesc="Easily and securely share files from the command line. A Send client."
|
|
url="https://gitlab.com/timvisee/ffsend"
|
|
license=('GPL3')
|
|
source=("git+${url}")
|
|
sha256sums=('SKIP')
|
|
arch=('x86_64' 'i686')
|
|
provides=('ffsend')
|
|
conflicts=('ffsend')
|
|
depends=('ca-certificates')
|
|
makedepends=('cargo' 'cmake' 'openssl>=1.0')
|
|
optdepends=('xclip: clipboard support')
|
|
|
|
prepare() {
|
|
cd "${pkgname%-git}"
|
|
|
|
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
|
|
}
|
|
|
|
build() {
|
|
cd "${pkgname%-git}"
|
|
|
|
export RUSTUP_TOOLCHAIN=stable
|
|
export CARGO_TARGET_DIR=target
|
|
cargo build --frozen --release
|
|
}
|
|
|
|
check() {
|
|
cd "${pkgname%-git}"
|
|
|
|
export RUSTUP_TOOLCHAIN=stable
|
|
cargo test --frozen
|
|
}
|
|
|
|
package() {
|
|
cd "${pkgname%-git}"
|
|
|
|
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/ffsend"
|
|
|
|
# Shell completions and LICENSE file
|
|
install -Dm644 "contrib/completions/ffsend.bash" \
|
|
"$pkgdir/etc/bash_completion.d/ffsend"
|
|
install -Dm644 "contrib/completions/_ffsend" \
|
|
"$pkgdir/usr/share/zsh/site-functions/_ffsend"
|
|
install -Dm644 "contrib/completions/ffsend.fish" \
|
|
"$pkgdir/usr/share/fish/vendor_completions.d/ffsend.fish"
|
|
install -Dm644 "LICENSE" \
|
|
"$pkgdir/usr/share/licenses/ffsend/LICENSE"
|
|
}
|