37 lines
1.9 KiB
Bash
37 lines
1.9 KiB
Bash
# Maintainer: Tim Visee <tim@visee.me>
|
|
# Contributor: Ariel AxionL <i at axionl dot me>
|
|
#
|
|
# This PKGBUILD is managed externally, and is automatically updated here:
|
|
# - https://gitlab.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-bin/PKGBUILD
|
|
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-bin/PKGBUILD
|
|
|
|
pkgname=ffsend-bin
|
|
pkgver=0.0.0 # automatically set in CI, see: /.gitlab-ci.yml
|
|
pkgrel=1
|
|
pkgdesc="Easily and securely share files from the command line. A Send client."
|
|
url="https://gitlab.com/timvisee/ffsend"
|
|
license=('GPL3')
|
|
source=("ffsend-v$pkgver::https://github.com/timvisee/ffsend/releases/download/v$pkgver/ffsend-v$pkgver-linux-x64-static"
|
|
"ffsend-v$pkgver.bash::https://raw.githubusercontent.com/timvisee/ffsend/v$pkgver/contrib/completions/ffsend.bash"
|
|
"ffsend-v$pkgver.zsh::https://raw.githubusercontent.com/timvisee/ffsend/v$pkgver/contrib/completions/_ffsend"
|
|
"ffsend-v$pkgver.fish::https://raw.githubusercontent.com/timvisee/ffsend/v$pkgver/contrib/completions/ffsend.fish"
|
|
"LICENSE-v$pkgver::https://raw.githubusercontent.com/timvisee/ffsend/v$pkgver/LICENSE") # automatically set in CI, see: /.gitlab-ci.yml
|
|
sha256sums=('SKIP')
|
|
arch=('x86_64')
|
|
provides=('ffsend')
|
|
conflicts=('ffsend')
|
|
depends=('ca-certificates')
|
|
optdepends=('xclip: clipboard support'
|
|
'bash-completion: support auto completion for bash')
|
|
|
|
package() {
|
|
cd "$srcdir"
|
|
|
|
install -Dm755 "ffsend-v$pkgver" "$pkgdir/usr/bin/ffsend"
|
|
|
|
# Shell completions and LICENSE file
|
|
install -Dm644 "ffsend-v$pkgver.bash" "$pkgdir/usr/share/bash-completion/completions/ffsend"
|
|
install -Dm644 "ffsend-v$pkgver.zsh" "$pkgdir/usr/share/zsh/site-functions/_ffsend"
|
|
install -Dm644 "ffsend-v$pkgver.fish" "$pkgdir/usr/share/fish/vendor_completions.d/ffsend.fish"
|
|
install -Dm644 "LICENSE-v$pkgver" "$pkgdir/usr/share/licenses/ffsend/LICENSE"
|
|
}
|